Deputy not loading
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 03:53 UTC
Monitoring
We have implemented a fix and are monitoring recovery
Posted Nov 19, 2024 - 03:17 UTC
Identified
We have identified the issue and are currently working on a fix
Posted Nov 19, 2024 - 02:11 UTC
Update
We are continuing to investigate this issue.
Posted Nov 19, 2024 - 01:39 UTC
Investigating
We are currently investigating reports of Deputy not loading
Posted Nov 19, 2024 - 01:36 UTC
This incident affected: Deputy - All regions (Deputy - AU).