Timeouts & Connection issues
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted Aug 05, 2022 - 03:15 UTC
Update
Login Services have been restored. We are still seeing errors around billing and upgrading to different Deputy Plans. We are continuing to work around these; you may see timeouts within the billing and invoice section of your Deputy Account
Posted Aug 05, 2022 - 01:15 UTC
Identified
Due to downstream issues with our Billing provider Zuora, users may see connection issues or timeout reported when doing to perform certain tasks in Deputy. Our platform teams are currently looking at work arounds for this issue.
Posted Aug 04, 2022 - 21:45 UTC
This incident affected: Login Services and Billing Services.