504 error - Gateway timeout

Incident Report for Deputy.com

Resolved

This incident has been resolved.
Posted Sep 01, 2025 - 07:28 UTC

Update

We continue to monitor the recovery of the Deputy platform. All users should now be able to access without error.
Posted Sep 01, 2025 - 06:55 UTC

Monitoring

A fix has been deployed. iOS users of Deputy may still experience issues at this time.
Posted Sep 01, 2025 - 06:26 UTC

Identified

We have identified the issue and are actively working on a fix.
Posted Sep 01, 2025 - 05:32 UTC

Update

We are continuing to investigate this issue.
Posted Sep 01, 2025 - 05:24 UTC

Investigating

We're currently investigating reports of customers getting a "504 error - Gateway timeout" when accessing Deputy.
Posted Sep 01, 2025 - 04:44 UTC
This incident affected: Login Services and Deputy - All regions (Deputy - USA, Deputy - AU, Deputy - UK).