Bulk updates and bulk uploads not working

Incident Report for Deputy.com

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 08:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2026 - 07:26 UTC

Identified

We're aware of an issue where bulk updates and bulk uploads are not working.
We have identified this issue and are expecting this to be resolved by End of Day, AEST.
Posted Jan 16, 2026 - 02:55 UTC
This incident affected: Deputy - All regions (Deputy - USA, Deputy - AU, Deputy - UK).