Deputy Outage- People Tab, Analytics, Payroll, Timesheets

Incident Report for Deputy.com

Resolved

This incident has been resolved. If you're still experiencing issues please reach out to support@deputy.com
Posted Jul 10, 2026 - 21:16 UTC

Monitoring

The Launch Darkly service is recovering. We are currently monitoring the recovery at this time and applying additional fixes
Posted Jul 10, 2026 - 20:31 UTC

Update

Launch Darkly continues to have an outage. We are monitoring the Launch Darkly issue closely and also investigating possible alternatives fixes
Posted Jul 10, 2026 - 19:31 UTC

Update

We are continuing to work on a fix.
Posted Jul 10, 2026 - 19:00 UTC

Update

We are in the process of deploying a fix.
Posted Jul 10, 2026 - 18:14 UTC

Identified

We're actively monitoring the LaunchDarkly incident that is currently impacting Deputy accounts
Posted Jul 10, 2026 - 17:53 UTC

Investigating

We are currently investigating reports of outages throughout the Deputy platform
Posted Jul 10, 2026 - 17:40 UTC