Deputy HR access issue
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted Dec 06, 2023 - 03:52 UTC
Monitoring
A fix has been deployed. Customers who are subscribed to Deputy HR will now be able to access Hire, Onboarding and Documents once more
Posted Dec 06, 2023 - 03:18 UTC
Update
We have enabled the ability for customers to access the HR suite of products (Hire, Onboarding and Documents) whilst we release a fix.
Posted Dec 06, 2023 - 01:24 UTC
Identified
We have identified the issue and are currently working on a fix.
Posted Dec 06, 2023 - 01:09 UTC
Investigating
We are currently investigating reports of Deputy HR subscribers not being able to access Hire, Onboarding and Documents.
Posted Dec 06, 2023 - 00:58 UTC
This incident affected: Deputy - All regions (Deputy - USA, Deputy - AU, Deputy - UK).