Unable to approve and discard timesheets

Incident Report for Deputy.com

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 09:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 06, 2025 - 08:37 UTC

Update

We have identified the issue, and a fix is being implemented.
Posted Aug 06, 2025 - 07:53 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 06, 2025 - 06:53 UTC

Identified

The cause of the issue has been identified and a fix for this is in progress
Posted Aug 06, 2025 - 06:19 UTC

Investigating

We are currently investigating reports of being unable to approve and discard timesheets
Posted Aug 06, 2025 - 06:00 UTC
This incident affected: Deputy - All regions (Deputy - USA, Deputy - AU, Deputy - UK).