Schedule - Editing and Duplication Issues
Incident Report for Deputy.com
Resolved
The incident is now resolved
Posted Sep 12, 2024 - 15:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results
Posted Sep 12, 2024 - 14:42 UTC
Identified
The issue has been identified and we are working on a fix
Posted Sep 12, 2024 - 14:35 UTC
Investigating
We are currently investigating the reported issues and we will provide further updates shortly.
Posted Sep 12, 2024 - 14:25 UTC