Multiple accounts being displayed
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted Feb 12, 2024 - 05:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2024 - 04:46 UTC
Update
We are still investigating reports of customer accounts displaying multiple times. Currently, you may not be able to update settings for these accounts. The address reseller.deputy.com is currently redirecting to our status page.
Posted Feb 12, 2024 - 04:38 UTC
Investigating
We are currently investigating reports that customer accounts are being displayed multiple times when logging in via once.deputy.com.
Posted Feb 12, 2024 - 03:53 UTC
This incident affected: Login Services.