U.S. Trial accounts unable to convert to paid plan
Incident Report for Deputy.com
Resolved
We have resolved the issue impacting trial accounts in the U.S.
Posted May 06, 2023 - 01:49 UTC
Identified
We have investigated the cause of an issue impacting trial accounts in the U.S. converting to a paid plan and are working on a fix.
Posted May 05, 2023 - 22:14 UTC
Investigating
We are investigating a current issue regarding trial accounts in the U.S. being unable to convert to a paid plan
Posted May 05, 2023 - 21:58 UTC
This incident affected: Billing Services.