Analytics Reports Failing to Load

Incident Report for Deputy.com

Resolved

This issue has been resolved.
Posted Aug 05, 2026 - 17:29 UTC

Monitoring

Our Engineers have successfully restored full functionality to our analytics suite.
Posted Aug 05, 2026 - 17:23 UTC

Identified

We have identified the root cause and our engineers are working to restore functionality.
Posted Aug 05, 2026 - 16:27 UTC

Update

This outage is only impacting AMER businesses. We're still working to identify the cause.
Posted Aug 05, 2026 - 15:41 UTC

Investigating

We are currently investigating reports of analytics not loading.
Posted Aug 05, 2026 - 15:17 UTC