Google Maps Failure
Incident Report for Deputy.com
Resolved
Maps issue is now resolved, we thank you for your patience & co-operation.
Posted about 1 year ago. Oct 18, 2017 - 10:35 UTC
Investigating
There is still an ongoing issue with Maps, it is under thorough investigation with Google. We apologise for the inconvenience.
Posted about 1 year ago. Oct 18, 2017 - 03:54 UTC
Identified
We have ongoing issue with Maps being displayed correctly with Deputy Web Application. We are working with Google to resolve it ASAP
Posted about 1 year ago. Oct 18, 2017 - 00:30 UTC