Open Shifts

Incident Report for Deputy.com

Resolved

This incident has been resolved.
Posted May 20, 2024 - 23:22 UTC

Investigating

We are investigating reports that some team members are able to view (but not claim) open shifts for times when they have already been scheduled and that team members are a recommended option for shifts when they are already scheduled
Posted May 20, 2024 - 23:10 UTC
This incident affected: Deputy - All regions (Deputy - USA, Deputy - AU, Deputy - UK) and Deputy Website.