iOS Mobile App - Loading Issues

Incident Report for Deputy.com

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:21 UTC

Monitoring

The issue appears to have been resolved. We're monitoring to confirm it.
Posted Oct 20, 2025 - 18:37 UTC

Update

We are still investigating loading issues associated with the iOS mobile app.
Posted Oct 20, 2025 - 17:53 UTC

Investigating

We are currently investigating loading issues associated with the iOS mobile app.
Posted Oct 20, 2025 - 17:31 UTC
This incident affected: Deputy - All regions (Deputy - USA).