Unable to Access Deputy from IP Address in Spain

Incident Report for Deputy.com

Resolved

This incident has been resolved.
Posted May 20, 2025 - 21:31 UTC

Investigating

Deputy’s service delivery is supported by Fastly’s Edge CDN platform. We are aware that some customers in Spain may be unable to connect to Deputy due to ISP-level blocks on certain Fastly IP addresses.

If you are experiencing connectivity issues, please visit www.fastly-debug.com, and follow the instructions provided. Then, share the results with support@fastly.com. Deputy is working closely with Fastly, who will endeavour to resolve the matter directly with the ISP

We appreciate your patience as we work with Fastly to resolve this.
Posted May 14, 2025 - 08:55 UTC

Identified

We are aware that some customers are currently unable to access Deputy.

Our systems are not blocking any traffic from Spain, and we believe the issue may be related to outbound traffic from Spain to Deputy.
We are actively investigating the situation and seeking further clarity.
Posted May 13, 2025 - 20:07 UTC

Investigating

We are aware that some customers are currently unable to access Deputy.

Our systems are not blocking any traffic from Spain, and we believe the issue may be related to outbound traffic from Spain to Deputy.

We are actively investigating the situation and seeking further clarity.
Posted May 13, 2025 - 16:21 UTC