Fair Work Week - Regular Working Hours
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted May 17, 2024 - 20:18 UTC
Investigating
We are currently investigating an issue related to the inability to modify Regular Working Hours.
Posted May 17, 2024 - 19:27 UTC
This incident affected: Deputy - All regions (Deputy - USA).