Reports not loading for EU customers

Incident Report for Deputy.com

Resolved

This issue is now resolved
Posted Aug 07, 2025 - 09:27 UTC

Monitoring

A fix has been implemented and we are monitoring the results
Posted Aug 07, 2025 - 08:53 UTC

Identified

The issue has been identified and a fix has been implemented.
Posted Aug 07, 2025 - 08:48 UTC

Investigating

We are investigating Analytics reports aren't loading in the EU region
Posted Aug 07, 2025 - 07:52 UTC
This incident affected: Deputy - All regions (Deputy - UK).