Login Errors
Incident Report for Deputy.com
Resolved
This incident is now resolved.
Posted Feb 12, 2023 - 23:22 UTC
Update
This incident is now resolved.
Posted Feb 12, 2023 - 23:21 UTC
Investigating
We are currently investigating reports of errors when trying to access Deputy when logging in. You may see 504 or a something went wrong message
Posted Feb 12, 2023 - 22:29 UTC
This incident affected: Login Services and Deputy - All regions (Deputy - USA, Deputy - AU, Deputy - UK).