We’re investigating reports of degraded performance affecting some Deputy customers

Incident Report for Deputy.com

Resolved

Stable with continuous monitoring
Posted Feb 27, 2026 - 16:30 UTC

Investigating

Currently investigating reports of degraded performance affecting some Deputy customers
Posted Feb 27, 2026 - 14:22 UTC