Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 23, 2024 - 09:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 23, 2024 - 08:56 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 23, 2024 - 06:12 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 21, 2024 - 04:59 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 21, 2024 - 04:58 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 21, 2024 - 03:14 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 21, 2024 - 03:13 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 21, 2024 - 03:12 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 21, 2024 - 03:09 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 21, 2024 - 03:08 UTC
Scheduled
We want to alert you that Deputy will be performing planned maintenance on our US accounts for 2 hours on Friday, 23rd February, 01:00 PST to 02:00 PST (09:00 UTC to 10:00 UTC)
🚧 Maintenance Period:
US 🇺🇸 - Friday, 23rd February, 01:00 PST to 02:00 PST (09:00 UTC to 10:00 UTC)
⚠️ Accounts Impacted:
Accounts containing the following *na.deputy.com or *la.deputy.com within their Deputy URL. Example: charliescafe.na.deputy.com
During this window, Deputy services cannot be accessed and no actions can be performed. The following actions & not limited to these actions, will NOT be able to be performed: