On-boarding issues in Australia
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted Nov 04, 2019 - 04:07 UTC
Monitoring
We are no longer seeing more reports of Employee Onboarding issues. We will continue monitoring.
Posted Nov 04, 2019 - 02:25 UTC
Investigating
We are investigating reports of on-boarding issues affecting some of our customers in Australia. We will update once we know more.
Posted Nov 04, 2019 - 02:19 UTC
This incident affected: Deputy AU.