Paid Conversions
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted Oct 14, 2022 - 22:15 UTC
Identified
We have identified the issue for this incident and are working on a fix.
Posted Oct 14, 2022 - 21:28 UTC
Investigating
We are currently investigating an issue related to converting trial accounts to a paid subscription.
Posted Oct 14, 2022 - 19:42 UTC
This incident affected: Deputy - All regions (Deputy - USA, Deputy - AU, Deputy - UK) and Billing Services.