Potential Timesheet Issues 21-27 June 2023
Incident Report for Deputy.com
Postmortem

What has happened:

Deputy uses a system to handle some of our background processes and automates some elements of your business's workload. Unfortunately, that system temporarily failed, which has affected the following tasks:

  1. Automatically generating leave timesheets for employees who are on approved paid leave,
  2. Automatically rounding timesheets based on your location settings.

As a result, the accuracy of timesheets processed by your business between 21 June 2023 09:17 AEST (20 June 23:17 UTC) and 27 June 2023 10:45 AEST (00:45 UTC) may have been impacted.

What do I need to do to check:

If you have not run your payroll for the affected period;

  1. In Deputy, go to the Timesheets approval page, filter for the above dates, and review the accuracy of the timesheets — the steps in this help guide can assist you
  2. Run the Leave Management Report in Deputy to confirm which employees were on approved paid leave during this time and compare with the newly created leave timesheets in your Deputy account

If you have already run payroll for the affected period;

  1. You will need to compare timesheets from Deputy with your payroll provider to ensure that any missed time is appropriately accounted for.

Safeguarding against future issues

Our specialist technical team have conducted a thorough review of the incident and enhancements to our processes are currently being implemented to help ensure this system issue does not reoccur.

We are here to help

Our priority is to support you to minimise any impact on your business. If you have further queries, please contact our Support Team.

Posted Jul 03, 2023 - 03:44 UTC

Resolved
The system that runs background processes to automate some aspects of business workload, unfortunately experienced a temporary failure which has impacted timesheets during 21 June 2023 09:17 AEST (20 June 23:17 UTC) and 27 June 2023 10:45 AEST (00:45 UTC).

This system issue has been rectified.
Posted Jun 20, 2023 - 23:17 UTC