Unable to access Deputy

Incident Report for Deputy.com

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 02:25 UTC

Monitoring

Access to Deputy has been restored. We are continuing to monitor.
Posted Jul 28, 2025 - 02:10 UTC

Investigating

We're investigating reports of customers not being able to access Deputy within the APAC region.
Posted Jul 28, 2025 - 01:53 UTC
This incident affected: Deputy - All regions (Deputy - AU).