Unable to load legacy reports - Enterprise Accounts Only

Incident Report for Deputy.com

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 07:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 11, 2025 - 07:38 UTC

Update

We are still continuing to work on a fix. We expect our next update to be at 1900 AEST if there are no further changes.
Posted Jul 11, 2025 - 07:00 UTC

Update

We continue to work on a fix. We plan to provide a further update at 1700 AEST if there are no further changes.
Posted Jul 11, 2025 - 06:07 UTC

Identified

The issue has been identified and we are working on a fix. The issue only affects legacy reports on Enterprise accounts.
Posted Jul 11, 2025 - 05:08 UTC

Investigating

We are currently investigating reports of customers not being able to access legacy reporting within Deputy
Posted Jul 11, 2025 - 05:03 UTC
This incident affected: Deputy - All regions (Deputy - USA, Deputy - AU, Deputy - UK).