Deputy Performance issues (US)

Incident Report for Deputy.com

Resolved

This issue is now resolved
Posted Jul 24, 2026 - 13:12 UTC

Identified

We are aware of potential performance issues caused by an AWS Operational Issue. We are currently monitoring this issue closely
Posted Jul 24, 2026 - 12:20 UTC
This incident affected: Deputy - All regions (Deputy - USA).