Platform access issue
Incident Report for Deputy.com
Resolved
This incident has been resolved - for full details about the AWS incident please see - https://health.aws.amazon.com/health/status
Posted Sep 19, 2023 - 06:17 UTC
Update
Deputy Customers should no longer see issues with the Platform. AWS continues to work on resolving this issue. Whilst they do we will keep this issue open and provide updates as they recover. For more information on the AWS issue see https://health.aws.amazon.com/health/status
Posted Sep 19, 2023 - 01:40 UTC
Update
Deputy Customers should no longer see issues with the Platform. From the last update from AWS, we expect this issue to be fully resolved within the next 60 to 90 minutes. We will continue to monitor the recovery of the system.
Posted Sep 18, 2023 - 23:29 UTC
Update
The reported outage appears now to be resolved. The latest fix from AWS appears to have resolved this for Deputy Customers who can now log in, clock off and export. We will continue to monitor the recovery of the system.
Posted Sep 18, 2023 - 22:53 UTC
Monitoring
AWS has applied a fix to their infrastructure. This fix appears to be showing improvements to the system and we are seeing that Deputy customers may now be able to log in and use Deputy. For more information see - https://health.aws.amazon.com/health/status
Posted Sep 18, 2023 - 22:13 UTC
Update
Deputy continues to be affected by an AWS issue in North America. We are still working with our teams to find a workaround for this issue.
Posted Sep 18, 2023 - 20:37 UTC
Identified
Deputy is being affected by an AWS issue in North America. We are currently investigating a work around for this issue.
Posted Sep 18, 2023 - 19:32 UTC
Investigating
We are investigating reports of customers not being able to access the platform in the North America region
Posted Sep 18, 2023 - 19:12 UTC
This incident affected: Login Services and Deputy - All regions (Deputy - USA).