Website update
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted about 2 years ago. Nov 04, 2015 - 06:46 UTC
Monitoring
We are doing a *slight* marketing website update for deputy.com. Some hiccups may be experienced
Posted about 2 years ago. Nov 04, 2015 - 05:21 UTC