Timesheet 2.0 slow loading and changes failing to update
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 06:05 UTC
Update
We continue to monitor as we roll out additional changes to the system.
Posted Nov 18, 2024 - 03:42 UTC
Monitoring
We have implemented a fix and are monitoring the results.
Posted Nov 18, 2024 - 03:00 UTC
Identified
We've identified the issue and are working on a fix.
Posted Nov 18, 2024 - 01:06 UTC
Investigating
We're currently investigating an issue with the Timesheet 2.0 experience. Customers may see that changes made to timesheets may not be updated and slow loading times.
Posted Nov 18, 2024 - 00:47 UTC
This incident affected: Deputy - All regions (Deputy - AU).