Downgrading service error
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted Oct 21, 2024 - 03:04 UTC
Investigating
We are currently aware of a performance issue impacting our downgrading service, we are currently investigating this.
Posted Oct 20, 2024 - 23:58 UTC
This incident affected: Billing Services.