Performance issues - All regions
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted Aug 19, 2020 - 22:56 UTC
Monitoring
We've identified the issue and applied a fix; we're currently monitoring performance
Posted Aug 19, 2020 - 22:37 UTC
Investigating
We are currently investigating reports of performance issues in all regions
Posted Aug 19, 2020 - 22:27 UTC
This incident affected: Deputy - All regions (Deputy - USA, Deputy - AU, Deputy - UK) and Login Services.