Incorrect Timesheet Dates

Incident Report for Deputy.com

Resolved

This issue has been resolved.
Posted Jul 24, 2024 - 16:58 UTC

Update

A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2024 - 16:01 UTC

Update

We've identified the cause of the problem and are working on the fix
Posted Jul 24, 2024 - 15:46 UTC

Investigating

We are currently investigating an issue related to timesheet dates showing incorrectly. Our engineering teams are working to identify and resolve the cause of this issue.
Posted Jul 24, 2024 - 14:57 UTC