Signup and login issues
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted almost 3 years ago. Dec 01, 2016 - 12:45 UTC
Investigating
Currently we are facing an issue signup and login service. We are working on fixing it ASAP..
Posted almost 3 years ago. Dec 01, 2016 - 11:12 UTC