Unable to Login

Incident Report for Deputy.com

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 03:08 UTC

Monitoring

We're seeing the Deputy platform recover and currently monitoring the system
Posted Apr 10, 2025 - 02:23 UTC

Update

We are continuing to investigate this issue.
Posted Apr 10, 2025 - 02:14 UTC

Investigating

We're investigating reports of not being able to log into Deputy and 504 errors being shown to end users
Posted Apr 10, 2025 - 02:10 UTC
This incident affected: Login Services and Deputy - All regions (Deputy - USA, Deputy - AU, Deputy - UK).