Security update
Incident Report for Deputy.com
Resolved
All done.... Thank you for your patience
Posted almost 3 years ago. Oct 24, 2014 - 20:15 UTC
Update
Some customers should be ok now. Working through the rest. Sorry for the interruption
Posted almost 3 years ago. Oct 24, 2014 - 20:09 UTC
Investigating
We are performing urgent security upgrade. Service will be back shortly. ETA 20 mins
Posted almost 3 years ago. Oct 24, 2014 - 19:39 UTC