Availability issues - All regions
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted May 25, 2020 - 05:07 UTC
Monitoring
We've identified the issue and are now recovering. We will continue to monitor.
Posted May 25, 2020 - 04:51 UTC
Update
We are continuing to investigate this issue.
Posted May 25, 2020 - 04:46 UTC
Investigating
We are currently investigating reports of availability issues accessing Deputy in all regions. Currently users are not able to login via once.deputy.com
Posted May 25, 2020 - 04:42 UTC
This incident affected: Deputy - All regions (Deputy - USA, Deputy - AU, Deputy - UK) and Login Services.