Website issue
Incident Report for Deputy.com
Resolved
Deputy website is now fully functional! Thank you for your patience :)
Posted over 2 years ago. Jul 31, 2015 - 11:36 UTC
Investigating
We are updating our website and there are some issues as it is propagating. We are actively working on it
Posted over 2 years ago. Jul 31, 2015 - 08:27 UTC