Load issues due to CloudFront DNS
Incident Report for Deputy.com
Resolved
This incident has been resolved.
Posted almost 3 years ago. Nov 27, 2014 - 02:27 UTC
Monitoring
Amazon DNS problems have been resolved. The services are coming back online slowly
Posted almost 3 years ago. Nov 27, 2014 - 02:25 UTC
Investigating
Our service provider amazon is having some issues http://status.aws.amazon.com They are working to resolve it soon. Kiosk and the Apps will continue working fine. Website may fail to load partially
Posted almost 3 years ago. Nov 27, 2014 - 01:26 UTC